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Getting Started

Learning about system requirements

The following information is current as of this guide’s publication date, and is subject to change. 

You can access the current ONESOURCE WorkFlow Manager system requirements from 
ONESOURCE platform as well. To do so, from the Help menu, select User Documentation, 
then select System Requirements.

Operating System

Microsoft Windows XP Professional SP2 or SP3•	
Microsoft Windows Vista Business SP1•	
Microsoft Windows 7 32-bit •	

Note: Microsoft SOAP 3.0 Toolkit is required for 
Windows 7 only.

Hardware Minimum Intel 1.8 ghz processor/Dual Core processor

Memory Minimum 1 GB RAM/2 GB RAM

Microsoft Office
2003, 2007, or 2010 (32-bit only)
Note: “Protected View” must be disabled if using MS Office 
2010.

Screen Resolution 1024 x 768 minimum

Network Protocol
TCP/IP Network Protocol Internet connection 
Minimum768 Kbps if single user/3 Mbps for multiple users

Windows Internet Explorer

Internet Explorer 6, 7, or 8
Notes: 

Compatibility Mode is required for 64-bit versions of IE. •	
“Protected Mode” must be disabled if using Windows 7.•	

Additional Components Available through the Check Browser link on the Login page
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Checking your browser

To get the most out of ONESOURCE, click the Check Browser link on the Login page to ensure 
that your computer is in compliance. The Check Browser window appears.

In the Enabled column, review which adjustments need to be made to your browser. These may 
include upgrading to newer software versions or enabling settings.

Note: For more information regarding current system requirements, please refer to the System 
Requirements document located within the Release Notes gadget.

Microsoft Internet Explorer

Download Internet Explorer at http://www.microsoft.com/windows/downloads/ie/getitnow.mspx. 

Browser Cookies

Internet Explorer allows you to specify sites from which to allow cookies. To do so, complete the 
following steps.

Open Internet Explorer, select 1.	 Tools, then Internet Options.

Click the 2.	 Privacy tab, then click Sites.

Type the following sites in the3.	  Address of website field:

https://*.onesourcelogin.com•	

https://*.onesourcetax.com•	

https://*.thomson.com•	

Click 4.	 Allow after typing each site’s address.

Click 5.	 OK in the Per Site Privacy Actions dialog box.

Click 6.	 OK in the Internet Options dialog box.

Allow Pop-up Windows

Open Internet Explorer and select 1.	 Tools, then Pop-up Blocker, then Pop-up 
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Blocker Settings.

Type the sites listed above into the 2.	 Address of website to allow field. Click Add 
after entering each site.

Click 3.	 Close.

Trusted Site Security Settings

Open Internet Explorer, select 1.	 Tools, then Internet Options.

Click the 2.	 Security tab, then the Trusted Sites icon, then Sites.

Type the following sites into the 3.	 Add this website to the zone field. 

https://*.onesourcelogin.com•	

https://*.onesourcetax.com•	

https://*.thomson.com•	

Note: Click Add after entering each site.

Click 4.	 Close in the Trusted sites dialog box.

Click 5.	 OK in the Internet Options dialog box.

Protected Mode

Protected Mode must be disabled in the Trusted Sites Zone.

Compatibility View

Compatibility View should be enabled in Internet Explorer 8.

ActiveX Controls and Plug-ins

Allow previously unused ActiveX controls to run without prompt: •	 Enable

Allow Scriptlets: •	 Enable

Automatic prompting for ActiveX controls: •	 Enable

Binary and script behaviors: •	 Enable

Download signed ActiveX controls: •	 Enable

Initialize and script ActiveX controls not marked as safe for scripting: •	 Enable

Run ActiveX controls and plug-ins: •	 Enable

Script ActiveX controls marked safe for scripting: •	 Enable

Downloads

Automatic prompting for file downloads: Enable

Miscellaneous

Access data sources across domains: •	 Enable

Display mixed content: •	 Enable

Use Pop-up Blocker: •	 Disable
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Internet Explorer Advanced Options

Do not save encrypted pages to disk: Disable

Silverlight

You may be prompted to install the latest version of Microsoft Silverlight. The benefits of using 
Silverlight include more intuitive usability for end users and faster performance when processing 
large volumes of data. 

To install Silverlight, click Install Now link from the popup window that appears.

Adobe Flash Player

OneSource supports Adobe Flash Player 7 and above. To upgrade, visit the Adobe Web site at  
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash.

Adobe Reader and Adobe Acrobat

OneSource supports Adobe Reader and Adobe Acrobat professional products version 6 and 
above. Download the most recent version of Adobe Reader at http://www.adobe.com/products/
acrobat/readstep2.html?promoid=BUIGO.

Tip: If you have Adobe Reader and later upgrade to a full version, make sure that you uninstall 
Adobe Reader first.

Common Controls Active X, MSXML, and Visual Basic Virtual Machine

Links are provided for Common Controls Active X, MSXML 4.0 SP2, and Visual Basic Virtual 
Machine. If applicable, click the link and follow the instructions provided.

Enabling macros in Microsoft Excel

All DataFlow templates sent to data providers will be digitally signed to ensure that code has not 
been compromised.

To open the Excel files sent through DataFlow requests, make sure that you change the macro 
security settings to accept digitally signed files.

Enabling macros in Excel 2007 and 2010

In Excel 2007 and 2010, you enable macros within the Trust Center window. To do so, complete 
the following steps.

From the Excel main menu, click 1.	 Excel Options. The Excel Options window 
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appears.

Select 2.	 Trust Center from the left side menu, then click Trust Center Settings 
from the Microsoft Office Excel Trust Center section. The Trust Center 
window appears.

Select 3.	 Macro Settings from the left side menu.

Select 4.	 Disable all macros except digitally signed macros.

Click 5.	 OK.

Enabling macros in Excel 2003

In Excel 2003, you enable macros within the Tools menu. To do so, complete the following steps.

From the 1.	 Tools menu, select Macro, then select Security. The Security dialog 
box appears.

Click the 2.	 Security Level tab, then select High. 

The High security level will allow you to open macros from trusted sources, 
but will disable macros from unknown sources. To learn more about signed and 
unsigned macros, visit http://office.microsoft.com/en-us/excel/hP011195791033.
aspx.

Click the3.	  Trusted Publishers tab, then add a list of trusted publishers from which 
Excel can open files with macros.

Click 4.	 OK.

http://office. microsoft.com/en-us/excel/hP011195791033.aspx
http://office. microsoft.com/en-us/excel/hP011195791033.aspx
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The Data Provider

As a data provider, you will receive email notification of any new DataFlow requests assigned to 
you. To complete these requests, you must log in to ONESOURCE WorkFlow Manager to access 
the DataFlow template, add notes and documents to the request, change the status, and monitor 
the request. 

Receiving a DataFlow request

When a DataFlow request is created, data providers assigned to the request will receive email 
notification.

The email provides details of the request, including the Entity or Topic for which the request 
pertains, Template Name, Year, and Period.

Click DataFlow Login or access this site directly at https://workflow.onesourcetax.com/IWM/
Login.aspx?laction=DataFlow.

Understanding the My DataFlow Requests window

After logging in to ONESOURCE WorkFlow Manager, the My DataFlow Requests window 
opens, and provides detailed information about each DataFlow request assigned to you.

https://workflow.onesourcetax.com/IWM/Login.aspx?laction=DataFlow
https://workflow.onesourcetax.com/IWM/Login.aspx?laction=DataFlow
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The My DataFlow Requests window includes the following elements:

Arrows: •	 If there are more requests than will fit within one window, click the left 
and right arrows to move from page to page. 

Buttons:•	  The My DataFlow Requests window includes the following buttons:

Open: –– Click Open to open the FormsFlow template or to access a DataFlow 
request.

Status: –– Click Status to change the status of the request. 

Docs:––  Click Docs to access or add documents.

Notes: –– Click Notes to add or read notes related to the request.

My DataFlow Requests grid:•	  This grid contains a list of DataFlow requests 
assigned to you with information about each, including Entity Name, Entity ID, 
Status, and Due Date.

Filters:•	  The Group Code, Scenario, and Status lists allow you to filter your 
DataFlow requests as needed. Select a filter to use, then click Filter.

Options: •	 The Options menu provides links to remove the FormsFlow Add-In, as 
well as to access DataFlow documentation. 

Note: The Add-In is no longer necessary, but some data providers may still 
have it installed on their systems.

Logout:•	   Logs you out of ONESOURCE WorkFlow Manager.

Opening a request

Click Open to access a DataFlow request.

Please refer to the “Completing a FormsFlow Web-based Excel Template” section for additional 
information about opening DataFlow requests.
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Learning about the Checked Out By column

Only one user at a time can access a request for editing. While in edit mode, the request is 
considered “checked out”. All other users can access the request in read-only mode. The user’s 
name, date, and time appears in the Checked Out By column of the grid.

To ensure that requests are not checked out indefinitely, administrators can limit checkout times. 
Ask your administrator about any limitations on your checkout time.  

Note:  Each time that you save data to ONESOURCE, the checkout time is reset.  	

Changing the status of a request

To change the status of a request, complete the following steps.

1. 	 Click Status. The Update Status dialog box appears.

2.	 Select a status for the request.

3.	 Click Save. Email notifications will be sent to users assigned to this request.

Accessing documents

Click Docs to access a DataFlow document.

Please refer to the “Working with DataFlow documents” section for additional information about 
accessing documents.
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Accessing notes

Click Notes to access a DataFlow note.

Please refer to the “Working with DataFlow notes” section for additional information about 
accessing notes. 

Filtering DataFlow requests

You can filter requests in the My DataFlow Requests grid using the Group Code, Scenario, and 
Status filters. 

To filter your requests, complete the following steps.

1.	 From the Group Code, Scenario, and Status lists, select the criteria to apply to 
the search.

2.	 Click Filter. Only those requests matching your filter criteria will appear.

To view all requests again, complete the following steps.

1.	 From the Group Code, Scenario, and Status lists, select ALL.

2.	 Click Filter.

Learning about the Options menu

The Options menu provides you with the following selections:

A link to remove the FormsFlow Add-In•	

Access to the •	 ONESOURCE DataFlow Data Provider Guide

Removing the FormsFlow Add-In

Previous versions of DataFlow required data providers to download and install a FormsFlow Add-
In which allowed them to complete FormsFlow Templates. The Add-In is no longer necessary 
since the tools necessary to work with these templates are embedded within the worksheets.

To remove the FormsFlow Add-In from your system, complete the following steps.

1.	 From the Options menu, select Remove FormsFlow. 
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2.	 Click Open to start the removal process.

3.	 Click Run to continue the removal process.

The FormsFlow menu will now only appear on your Excel menu when you are 
working on a FormsFlow template.

Accessing the ONESOURCE DataFlow Data Provider Guide

To open the ONESOURCE DataFlow Data Provider Guide as a PDF file, from the Options 
menu, select User Guide.

The ONESOURCE DataFlow Data Provider Guide opens in a separate Adobe Acrobat Reader 
window.
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Completing a FormsFlow  
Web-based Excel Template

Learning about the FormsFlow template options

When you open a FormsFlow template in Excel, available options appear within the following 
areas:

The •	 FormsFlow menu located on the Add-Ins tab

The •	 FormsFlow toolbar located on the Microsoft Excel ribbon

Options for FormsFlow menu on Add-Ins tab

Options for FormsFlow toolbar on Microsoft Excel ribbon 

Note:  The template designer determines which menu options are available to you. Your menu 
and toolbar will display only those functions to which you have been granted access.  

Hiding the toolbar in Excel 2003

To hide the FormsFlow toolbar in Excel 2003, from the View menu, select Toolbars, then clear 
the FormsFlow check box.
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Using the FormsFlow menu or toolbar

The FormsFlow menu and toolbar includes the following options:

Save Data•	

Load Data•	

Clear Data•	

Duplicate Page•	

Add Rows•	

Fit Text•	

Print•	

Local Options•	

Save Data

Select Save Data to save data from the FormsFlow template to the DataFlow repository. This 
is the preferred method of saving data. However, you can select Save from the File menu to 
accomplish the same thing.

Load Data

Select Load Data to repopulate the FormsFlow template in the event of errors. When you open a 
saved template, it is reloaded with data from the DataFlow repository.

NOTE: This will overwrite any information not already saved to the server.

Clear Data

Select Clear Data to delete all information from the page on which you entered data, not just the 
selected cell.

Duplicate Page

If a page can be duplicated, a message telling you “This worksheet can be duplicated” appears at 
the top of the worksheet.

Select Duplicate Page to insert a new worksheet with the name of the original worksheet. The 
system adds the prefix Pxx, where xx is the number of duplicated pages (e.g., P01, P02). 

The duplicate sheet contains the same data as the original sheet. To remove all data from the new 
sheet, click anywhere in the sheet and select Clear Data from the FormsFlow menu or toolbar.  

Add Rows

You can add rows to input areas as necessary. Eligible rows appear with the “Add Rows” 
designation. 
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To add a row, complete the following steps.

1.	 Select any cell in the Add Rows group. 

Note: Make sure that you select a single cell and that the cursor is not in data 
entry mode (i.e. the cursor should not be blinking).

2. 	 Select Add Rows from the FormsFlow menu or toolbar. The Add Rows dialog 
box appears.

	

3.	 Type the number of rows to add, then click OK.

NOTE: Since unused rows cannot be deleted, we recommend that you are 
conservative when adding rows. 

Fit Text

Input areas identified with the “Fit Text” designation allow you to enter more data than will fit in 
the cell.

To fit the text that you entered in the cell, complete the following steps.

1. 	 Select the cell that contains your text. 

Note: Make sure that you select a single cell and that the cursor is not in data 
entry mode (i.e. the cursor should not be blinking).

2.	 Select Fit Text from the FormsFlow menu or toolbar.

Print

To print the current worksheet or the entire workbook, select Print from the FormsFlow menu or 
toolbar. The Print dialog box appears.

Select•	  Print Active Worksheet to send the current page to the printer.
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Select•	  Print Entire Workbook to send all pages in the workbook to the printer.

Local Options

Select Local Options, then select one of the following options to save the FormsFlow template 
and your data to your computer:

Save Data Locally•	

Copy to Template File•	

Load Data From Local File•	

Doing so can be useful if you plan to work offline. When you are online again, you can save your 
FormsFlow template to the server.

Note: The system saves the FormsFlow template and the data that you enter as two separate 
files. They are combined when you select Load Data From Local File.  

Save Data Locally

To save data to your local drive, complete the following steps.

1.	 From the FormsFlow menu or toolbar, select Local Options, then select Save 
Data Locally. The Save Data Locally dialog box appears.

2.	 Select the drive and folder in which you will save your file.

The file name defaults to the following format:

<EntityID>_<EntityName>_<TemplateName>_<Year>.xml as shown in the 
example above. You can change the file name, but the file type must remain .xml. 

3.	 Click Save.

Copy to Template File 

The Copy to Template File option saves the template without data to your local drive. To do so, 
complete the following steps.

1. 	 From the FormsFlow menu or toolbar, select Local Options, then select Copy 
To Template File. A message appears, and reminds you to use the Save Data 
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Locally option to save your data.

Note:  To work locally, select Save Data Locally instead.

2.	 Click OK. The file name defaults to the following format:

<EntityID>_<EntityName>_<TemplateName>_<Year>.xls. You can change 
the template file name, but the file type must remain .xls. 

4.	 Click Save.

Load Data From Local File

Remember that the FormsFlow template and the data that you enter are saved as two separate 
files. You can combine the files by completing the following steps.   

1. 	 Open the FormsFlow template that you saved to your local drive in .xls format.  

2. 	 From the FormsFlow menu or toolbar, select Local Options, then select Load 
Data From Local File. 

3.	 Open the data file that you saved to your local drive in .xml format. This will 
load the data into the FormsFlow template. 

4.	 Continue adding data as necessary.

5.	 From the FormsFlow menu or toolbar, select Local Options, then select Save 
Data Locally. 

6.	 Click Yes to save the file.

When you are ready to transfer the data from your FormsFlow template on your local drive to the 
FormsFlow template on the server, complete the following steps.

1. 	 Log in to OneSource DataFlow.

2. 	 Open the appropriate request from the My DataFlow Requests grid. 

3. 	 Select Local Options from the FormsFlow menu or toolbar, then select Load 
Data From Local File to overwrite the file with the data that you updated on 
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your local drive.

4. 	 Click Save Data from the FormsFlow menu or toolbar. 

Working with DataFlow documents

You can add, view, or delete documents related to your DataFlow requests. When documents have 
been added to a DataFlow request, the Documents icon ( ) appears.

Note: You must have permission to access, add, or delete documents for a DataFlow request. If 
you cannot access documents, contact the originator of your request.

To work with DataFlow documents, complete the following steps.

1.	 Log in to OneSource DataFlow.

2. 	 Open the appropriate request from the My DataFlow Requests grid. 

3.	 Click Docs. 

The DataFlow Documents dialog box for this request appears.

Add a document:•	  To add a document, in the Add Document section, type a 
description of the document in the Description field, click Browse to locate 
the file, then click Save.

Open a document: •	 To open an attached document, in the Attached 
Documents section, double-click a document description.

Delete a document:•	  To delete a document, in the Attached Documents 
section, click Delete to the right of the document description.

5.	 Click Close Window in the top right corner to close the DataFlow Documents 
dialog box.
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Working with DataFlow notes

You can add, resolve, and close notes related to your DataFlow requests. When notes have been 
added to a DataFlow request, the Notes icon ( ) appears.

Note:  You must have been granted permission to access or add Notes on a DataFlow request.  
If you cannot access Notes, contact the originator of your request.

To work with DataFlow notes, complete the following steps.

1.	 Log in to OneSource DataFlow.

2. 	 Open the appropriate request from the My DataFlow Requests grid. 

3.	 Click Notes to open the DataFlow Notes screen for this request.

The DataFlow Notes dialog box for this request appears.

Add a note:•	  To add a note, in the Add Note section, type your comments 
in the Note field, add a resolution in the Resolution field as necessary, then 
click Save.

Open a note: •	 To open a note, in the Notes section, double-click a note 
description.

Close a note:•	  To close a note, select the Closed check box.

Delete a note:•	  To delete a note, in the Notes section, click Delete to the right 
of the note description.

5.	 Click Close Window in the top right corner to close the DataFlow Notes dialog 
box.
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Working with DataFlow documents and notes

If a DataFlow request has documents and notes attached to it, both the Documents and Notes 
icons appear on the far left of the row ( ). 
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